4 razones por las que deberías usar PHP 7 con Joomla!
Joomla! y PHP 7
Modificado por última vez en Miércoles, 13 Diciembre 2017 09:19
(0 votos)

4 razones por las que deberías usar PHP 7 con Joomla!

Joomla 4 tendrá grandes mejoras tanto para usuarios como para desarrolladores

Con la perspectiva de Joomla 4 el próximo año nos gustaría crear conciencia sobre la necesidad de actualizar a PHP 7. Joomla 4 requerirá ejecutar PHP 7, como se indica en este anuncio. La mayoría de los hosts ya ofrecen PHP 7 en sus paquetes y debería ser bastante fácil cambiar tu versión de PHP. (Sugerencia: antes de hacerlo, asegúrate de realizar una copia de seguridad). De lo contrario, ponte en contacto con tu alojamiento.

Dejanos darte 4 razones por las que no debes esperar para actualizar PHP.

PHP 7 es mejor

Fácil de decir, por supuesto, pero PHP 7 en realidad tiene una mejora en el rendimiento que hace que un sitio web funcione el doble de rápido (en comparación con PHP 5) y tiene un consumo de memoria un 50% mejor. Por supuesto, PHP 7 tambien es más seguro y te permite hacer más como desarrollador.

Joomla 4 será increíble

Joomla 4 tendrá grandes mejoras tanto para usuarios como para desarrolladores. Un código limpio, un marco (framework) renovado, excelentes nuevas funciones y mucho más. Bootstrap 4 se implementará en el núcleo, habrá 2 nuevas plantillas (frontend y backend), el nuevo administrador de medios será amado por muchos. Como Joomla 4 está aún en desarrollo y se predice para la segunda mitad de 2018, la lista de increíbles características seguirá ampliándose y se anunciará antes del lanzamiento.

Marco renovado

El renovado marco (versión 2.0) que viene con Joomla 4 tiene algunas mejoras importantes. La API de base de datos admitirá de forma nativa las declaraciones preparadas, que es una importante mejora de seguridad. El almacenamiento de datos encriptados será ahora posible con un componente de Keychain más modular. Las herramientas de línea de comandos pueden ser mejores y más seguras gracias al nuevo componente de la consola.

Para obtener una lista completa de características, visita la hoja de ruta.

Es más seguro y compatible

Las versiones anteriores a PHP 5.6 ya no son compatibles con las correcciones de seguridad. Si se encuentra una gran vulnerabilidad en PHP 5.3, nadie va a solucionarlo y un sitio será vulnerable. Al utilizar la última versión siempre sabrás que se ocuparán de esos posibles problemas, y las actualizaciones estarán disponibles muy rápidamente cuando haya una.

Como PHP 7 es la última versión principal, será compatible durante mucho tiempo (incluidas las versiones menores) por lo que tu sitio web Joomla 4 se ejecutará fácilmente hasta 2025.

Pero, pero ... ¿Que pasa si no puedo actualizar?

Una cosa importante para recordar es que Joomla 3.9 será compatible durante dos años despues de su lanzamiento. Esto significa que se puede ejecutar cómodamente un sitio Joomla 3 hasta el año 2020, pero se perderá todas las características y ventajas de Joomla 4. Pero seamos sinceros, si tu alojamiento no soporta ahora PHP 7, podría ser bueno buscar en otra empresa de hosting.


Comentarios (0)

No hay comentarios escritos aquí

Deja tus comentarios

Publicar comentario como invitado. Regístrate o ingresaa tu cuenta
0 Caracteres
Archivos adjuntos (0 / 3)
Compartir su ubicación
close

Recibe gratis nuestros nuevos artículos!

Serás el primero en conocer las novedades y noticias que pasan en Internet, nuestros tutoriales, trucos y más.

Escribe tu email:

Se abrirá una nueva ventana de FeedBurner a la izquierda de la página y habrás de validar un Captcha.

Lee nuestras Política de privacidad & Política de cookies
Puedes darte de baja de la lista de correo electrónico en cualquier momento