Importantes cambios de seguridad en Joomla! 3.3

Modificado por última vez en Jueves, 06 Febrero 2014 21:54
(0 votos)

Preparado para Joomla 3.3

La versión mínima requerida de PHP para Joomla! 3.3 será PHP 5.3.10

La próxima versión, Joomla! 3.2.2, pondrá a prueba nuestra versión de PHP (será lanzada la semana que viene)

El Joomla! Production Leader Team (PLT) ha anunciado los principales cambios en materia de seguridad que serán introducidas en la versión 3.3 de Joomla! como una introducción a la liberación de la versión 3.5 a finales de año.

El cambio más importante en Joomla! 3.3 estará relacionado con PHP. La versión mínima requerida de PHP se elevará a 5.3.10. En este momento los requisitos oficiales del proyecto Joomla! ya afirman que la versión mínima de PHP es 5.3.1, pero la recomendado es 5.4 + . Como la mayoría de las empresas de alojamiento ya tienen instalada al menos la versión 5.3.1 de PHP, y en muchos casos superior a 5.4, este cambio no debería causar ningún problema para la mayoría de usuarios.

La próxima semana se espera para su descarga el lanzamiento de Joomla! 3.2.2. Esta versión pondrá a prueba nuestra versión de PHP y reportará a los usuarios un mensaje de informe posterior a la instalación en caso de que tenga que actualizar antes de la liberación de Joomla! 3.3.

Para estar seguros, se puede comprobar nuestra versión de PHP en este momento, no importa que versión de Joomla ! 3.x estés utilizando. Después de entrar en el área de administración de tu sitio web, simplemente vete a Sistema » Información de Sistema » Información de PHP.

versión PHP en la administración de Joomla

Si ves que tu versión de PHP es más baja que la 5.3.10 no te preocupes, ya que el Production Leader Team ha anunciado que todavía tendrás 6 meses de soporte completo después de la liberación de Joomla! 3.3.

Además, durante los seis meses posteriores a que sea liberada Joomla! 3.3, el proyecto Joomla! hará liberación de actualizaciones de seguridad, tanto para las versiones 3.2 y 3.3 (así como 2,5) por lo que cualquier nueva vulnerabilidad de una actualización puede ser parcheada sin demora con un solo clic sin necesidad de actualizar inmediatamente a Joomla! 3.3, dándonos tiempo para presentar una solicitud a nuestro proveedor de alojamiento pidiendo que actualicen su versión de PHP (o hacerlo tú mismo si eres el administrador del sistema, cosa que me tocará hacer a mí pues la versión PHP de mi servidor es como vemos en la imagen de arriba 5.3.3).

La mejor idea es ponerse en contacto con tu proveedor de alojamiento antes de instalar la liberación de Joomla! 3.2.2 y hacerle saber que necesitas actualizar a una versión superior de PHP. Joomla! 3.2 está trabajando muy bien, incluso en PHP 5.4/5.5, por lo que no hay razón para temer actualizar PHP inmediatamente. Para la mayoría de las empresas de alojamiento está a sólo unos clics.

Pero el problema es tener alguna versión inferior de Joomla! en el mismo servidor, como es también mi caso en que dos sitios web corren en Joomla! 1.5.26 y esta versión no es compatible con PHP 4 o superior (lo digo por experiencia, ya que me tocó regresar a un PHP más antiguo al ver los sitios caídos).


Comentarios (0)

No hay comentarios escritos aquí

Deja tus comentarios

  1. Publicar comentario como invitado. Regístrate o ingresaa tu cuenta
Archivos adjuntos (0 / 3)
Compartir su ubicación
close

Recibe gratis nuestros nuevos artículos!

Serás el primero en conocer las novedades y noticias que pasan en Internet, nuestros tutoriales, trucos y más.

Escribe tu email:

Se abrirá una nueva ventana deFeedBurner a la izquierda de la página y habrás de validar un Captcha.

Lee nuestras Política de privacidad & Política de cookies
Puedes darte de baja de la lista de correo electrónico en cualquier momento