Actualizamos a Joomla 3.10 y comprobamos la compatibilidad de componentes y plugins en Joomla 4

El proyecto Joomla! anunció ayer el lanzamiento de la nueva versión mayor, Joomla 4.0, junto con Joomla 3.10, conocida como "el puente".

En nuestro sitio hemos actualizado a Joomla 3.10 para comprobar la compatibilidad de paquetes, módulos y plugins para Joomla 4, ya que para actualizar de 3.9.x a Joomla 4, tienes que pasar por la última versión 3.10. No hay una ruta de actualización directa entre 3.9 y 4.x planeada ni soportada. Todas las actualizaciones pasan por la 3.10.

La documentación de Joomla tiene una sección dedicada a migraciones y mini-migraciones. La documentación relevante aquí es la mini-migración de Joomla 3.10.x a 4.x. Como en todo tipo de migraciones, la planificación es lo más importante. Planificar, planificar, planificar. La planificación hace que las migraciones se realicen sin problemas.

La guía ¿Por qué migrar? brinda definiciones sobre los diferentes tipos de migraciones, una auto-evaluación para determinar si estarías cómodo haciendo tu mismo la migración, enlaces a recursos para encontrar profesionales que te puedan ayudar, planificación y guías paso a paso.

El verificador de pre-actualización de Joomla 3.10

Joomla 3.10 The Pre-update Checker nos dirá qué paquetes, módulos y plugins no son compatibles, o no está comprobada su compatibilidad, con Joomla 4. Para ver cuales son lanzaremos en nuestro sitio la actualización a Joomla 3.10 de la cual tendréis un aviso en vuestro sitio:

aviso de actualización a Joomla 3.10

Pinchando en el botón azul "Update Now" del segundo aviso en rojo "Joomla 3.10 is available" nos aparecerá la pantalla para lanzar la actualización:

inicio de la actualización a Joomla 3.10

Pinchamos en Install the Update (Instalar la actualización) y esperamos unos segundos a que se complete. Nuestro sitio tiene ahora la versión 3.10 de Joomla.

Para que nos aparezca en nuestro sitio el verificador de pre-actualización de Joomla 3.10 (Pre-update Checker for Joomla 3.10.0) debemos cambiar las opciones de actualización de Joomla en Components → Joomla! Update → Options en la parte superior derecha de la pantalla:

actualización de Joomla

Y cambiar el Update Channel (Servidor de actualizaciones) a Testing (Pruebas) y Minimun Stability (Estabilidad mínima) a Stable (Estable):

opciones de actualización a Joomla 3.10

Pinchamos en el botón Guardar y Cerrar (Save & Close)

Yendo de nuevo a Components → Joomla! Update ahora nos aparecerá la pantalla de Pre-update Checker for Joomla 3.10.0

Pre-Update Check Joomla 3.10

Pinchar en la imagen para verla en su totalidad en una nueva pantalla

Primero se nos informa de la utilidad:

The pre-update check provides you with information about the readiness of your server, settings and installed extensions for the update.
You can find more information about this page and how to prepare for updating Joomla in the pre-update check documentation.

La comprobación previa a la actualización le proporciona información sobre la preparación de su servidor, la configuración y las extensiones instaladas para la actualización.
Puede encontrar más información sobre esta página y cómo prepararse para la actualización de Joomla en la documentación de verificación previa a la actualización.

Hay tres partes en el análisis de compatibilidad:

• Required PHP & Database Settings (Configuración requerida de PHP y base de datos) donde en condiciones normales si tu sitio ha estado funcionando bien hasta ahora aparecerá todo en verde.

• Extensions Pre-Update Check (Comprobación previa a la actualización de extensiones). Aquí podremos apreciar que nos aparece un mensaje en rojo "Update Information Unavailable (No disponible información para actualizar)" y un texto "Extension does not offer a compatible version for the selected target version of Joomla. This could mean the extension does not use the Joomla update system or the developer has not provided compatibility information for this Joomla version yet (La extensión no ofrece una versión compatible para la versión de destino seleccionada de Joomla. Esto podría significar que la extensión no usa el sistema de actualización de Joomla o que el desarrollador aún no ha proporcionado información de compatibilidad para esta versión de Joomla)" y debajo la lista de plugins, módulos y paquetes de los que Joomla no tiene información de compatibilidad con Joomla 4 porque no ha sido facilitada por el desarrollador o directamente no son compatibles por su antigüedad.

Como expliqué en mi artículo de ayer, aquí hay que tener mucho cuidado al deshabilitar estos componente si queremos actualizar a Joomla 4 ya que el sitio puede quedar fuera de línea o no verse como el original. Pero esto lo veremos con más detalle cuando el sistema nos ofrezca actualizar a Joomla 4.

• No Update Required (No se requiere actualización). La última parte nos ofrece una lista de los todos los componentes, plantillas, módulos, plugins y ficheros que si han pasado la compatibilidad y no requieren actualizarse o deshabilitarse.

Con la actualización a Joomla 3.10.0 no he tenido ningún problema y el sitio funciona con normalidad como antes, pero me temo que con la migración a Joomla 4 si que habrá problemas de compatibilidad en bastantes sitios por lo que aconsejo trabajar con prudencia.

Comments (0)

There are no comments posted here yet

Leave your comments

  1. Posting comment as a guest.
Attachments (0 / 3)
Share Your Location


Recibe gratis nuevos artículos por email:
Inicia sesión para suscribirte en Youtube

Somos apañados (ñ)
Suscribete

Más leído